// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bsecondid=([\d,]+)").unwrap();
let string = "\"/css/style.min.css HTTP/1.1\" 200 7832 index.php?firstId=5&secondid=4,6,8 HTTP/1.1\"
\"/css/style.min.css HTTP/1.1\" 200 7832 index.php?firstId=5&secondid=4,6,8 HTTP/1.1\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}