#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+?(\b1)?[\ .\/-]?((?(2)|(\b))|(\())\d{3}(?(?<=\(\d{3})\)|)[\ .\/-]?)?(?(1)|\b)\d{3}[\ .\/-]?\d{4}[\ ]?([xX][\ ]?\d{1,5})?\b"
Local $sString = "+ (513)899-1888" & @CRLF & _
"5138991888" & @CRLF & _
"8991888" & @CRLF & _
"1 5138991888" & @CRLF & _
"+5138991888 " & @CRLF & _
"(513)8991888" & @CRLF & _
"1(513)8991888" & @CRLF & _
"(5138991888 " & @CRLF & _
"+1 513-899-1888" & @CRLF & _
"1/513-899-1888" & @CRLF & _
"1(513)899-1888 X 8888" & @CRLF & _
"+1 513 899-1888 x 11111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")