const regex = /(\+?(\b1)?[\ .\/-]?((?(2)|(\b))|(\())\d{3}(?(?<=\(\d{3})\)|)[\ .\/-]?)?(?(1)|\b)\d{3}[\ .\/-]?\d{4}[\ ]?([xX][\ ]?\d{1,5})?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+?(\\b1)?[\\ .\\\/-]?((?(2)|(\\b))|(\\())\\d{3}(?(?<=\\(\\d{3})\\)|)[\\ .\\\/-]?)?(?(1)|\\b)\\d{3}[\\ .\\\/-]?\\d{4}[\\ ]?([xX][\\ ]?\\d{1,5})?\\b', 'gm')
const str = `+ (513)899-1888
5138991888
8991888
1 5138991888
+5138991888
(513)8991888
1(513)8991888
(5138991888
+1 513-899-1888
1/513-899-1888
1(513)899-1888 X 8888
+1 513 899-1888 x 11111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}