package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(.*?)\]`)
var str = `[A] + -[B123]=0
[Test[0]]=0
[value] in the [text[42]] and [1[2[3]]]!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}