re = /\[(.*?)\]/m
str = '[A] + -[B123]=0
[Test[0]]=0
[value] in the [text[42]] and [1[2[3]]]!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end