$re = '/\[(.*?)\]/m';
$str = '[A] + -[B123]=0
[Test[0]]=0
[value] in the [text[42]] and [1[2[3]]]!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);