import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[ \\t]*([^ \\t>]*)[ \\t]*>[ \\t]*(\\S+)[ \\t]*<[ \\t]*(?:\\1)[ \\t]*>";
final String string = "< datapt > 2 < datapt >\n"
+ " < xunit > mass < xunit >\n"
+ " < xval > 150.000245 < xval >\n"
+ " < yunit > abs < yunit >\n"
+ " < yval > 0.000000 < yval >";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}