import re
regex = re.compile(r"<[ \t]*([^ \t>]*)[ \t]*>[ \t]*(\S+)[ \t]*<[ \t]*(?:\1)[ \t]*>", flags=re.MULTILINE)
test_str = ("< datapt > 2 < datapt >\n"
" < xunit > mass < xunit >\n"
" < xval > 150.000245 < xval >\n"
" < yunit > abs < yunit >\n"
" < yval > 0.000000 < yval >")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")