re = /<[ \t]*([^ \t>]*)[ \t]*>[ \t]*(\S+)[ \t]*<[ \t]*(?:\1)[ \t]*>/m
str = '< datapt > 2 < datapt >
< xunit > mass < xunit >
< xval > 150.000245 < xval >
< yunit > abs < yunit >
< yval > 0.000000 < yval >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end