package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/wp-admin/(?:network/|user/)?[a-z-_]+\d?\.[a-z]+$`)
var str = `/wp-admin/LongFancy____-----Sitename___---Matches_My_Pattern.php
/wp-admin/user/test.php
/wp-admin/other/test.php
/wp-admin/network/test.php
/wp-admin/test.php
/wp-admin/2user.php`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}