import Foundation
let pattern = #"^/wp-admin/(?:network/|user/)?[a-z-_]+\d?\.[a-z]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/wp-admin/LongFancy____-----Sitename___---Matches_My_Pattern.php
/wp-admin/user/test.php
/wp-admin/other/test.php
/wp-admin/network/test.php
/wp-admin/test.php
/wp-admin/2user.php
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)