import re
regex = re.compile(r"^/wp-admin/(?:network/|user/)?[a-z-_]+\d?\.[a-z]+$", flags=re.MULTILINE)
test_str = ("/wp-admin/LongFancy____-----Sitename___---Matches_My_Pattern.php\n"
"/wp-admin/user/test.php\n"
"/wp-admin/other/test.php\n"
"/wp-admin/network/test.php\n"
"/wp-admin/test.php\n"
"/wp-admin/2user.php")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")