use strict;
my $str = 'For example:
preview_download_robot=View your beautiful Robot!
I would like to replace the word "Robot" with "Android", but only after the = symbol. It should apply to any variation of the word "Robot" (e.g., Robot, robot, Robot-ally, Robot., Robothelp, etc.), regardless of capitalization or punctuation. The replacement should occur without breaking the document structure. ';
my $regex = qr/(?i)(?:\G(?!^)|(?<==)).*?\Krobot/mip;
my $subst = 'Android';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";