import Foundation
let pattern = #"(?i)(?:\G(?!^)|(?<==)).*?\Krobot"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
For example:
preview_download_robot=View your beautiful Robot!
I would like to replace the word "Robot" with "Android", but only after the = symbol. It should apply to any variation of the word "Robot" (e.g., Robot, robot, Robot-ally, Robot., Robothelp, etc.), regardless of capitalization or punctuation. The replacement should occur without breaking the document structure.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Android"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)