using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\${\s?\S+\s?})";
string input = @"__________ ${ result-1 } ___ ___ ____${result-2} __ ${result-3}___ { ${result-4} }___ ______\${IGNORE-ME}______
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}