const regex = /(\${\s?\S+\s?})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\${\\s?\\S+\\s?})', 'gm')
const str = `__________ \${ result-1 } ___ ___ ____\${result-2} __ \${result-3}___ { \${result-4} }___ ______\\\${IGNORE-ME}______
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}