// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\${\s?\S+\s?})").unwrap();
let string = "__________ ${ result-1 } ___ ___ ____${result-2} __ ${result-3}___ { ${result-4} }___ ______\\${IGNORE-ME}______
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}