package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\((?:\B\+|\b00)?48\)|(?:\B\+|\b00)?48)?([ -])?(?(1)|\b)\d{3}[ -]?\d{3}[ -]?\d{3}\b`)
var str = `+48 123 456 789
123456789
123 456 789
123-456-789
(+48) 123 456 789
+48123456789
0048123456789
Things not to capture:
12 345 67 89
1234567899876543211
654564654654654654
spam
1231312asdasdf1231231
123321
+4863227124`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}