import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\((?:\\B\\+|\\b00)?48\\)|(?:\\B\\+|\\b00)?48)?([ -])?(?(1)|\\b)\\d{3}[ -]?\\d{3}[ -]?\\d{3}\\b";
final String string = "+48 123 456 789 \n\n"
+ "123456789\n\n"
+ "123 456 789 \n\n"
+ "123-456-789\n\n"
+ "(+48) 123 456 789\n\n"
+ "+48123456789\n\n"
+ "0048123456789\n\n\n"
+ "Things not to capture: \n\n"
+ "12 345 67 89\n"
+ "1234567899876543211\n"
+ "654564654654654654\n"
+ "spam \n"
+ "1231312asdasdf1231231\n"
+ "123321\n"
+ "+4863227124";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}