const regex = new RegExp('(\\((?:\\B\\+|\\b00)?48\\)|(?:\\B\\+|\\b00)?48)?([ -])?(?(1)|\\b)\\d{3}[ -]?\\d{3}[ -]?\\d{3}\\b', 'g')
const str = `+48 123 456 789
123456789
123 456 789
123-456-789
(+48) 123 456 789
+48123456789
0048123456789
Things not to capture:
12 345 67 89
1234567899876543211
654564654654654654
spam
1231312asdasdf1231231
123321
+4863227124`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}