import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*[+-]?\\d*\\.?\\d+(?:\\.\\d+)*(?:\\s*,\\s*[+-]?\\d*\\.?\\d+(?:\\.\\d+)*){9,}\\s*$";
final String string = "2,2.5,.5, .678 ,39,1.4.4.8,2.4,2.5,2.6,2.7\n"
+ "1,2,3,4,5,6,7, 8 , 9,0\n"
+ ".1,.2,.3.33.33,.4.5.4,8,9,8,7,.0,0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}