$re = '/^\s*[+-]?\d*\.?\d+(?:\.\d+)*(?:\s*,\s*[+-]?\d*\.?\d+(?:\.\d+)*){9,}\s*$/m';
$str = '2,2.5,.5, .678 ,39,1.4.4.8,2.4,2.5,2.6,2.7
1,2,3,4,5,6,7, 8 , 9,0
.1,.2,.3.33.33,.4.5.4,8,9,8,7,.0,0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);