const regex = /^\s*[+-]?\d*\.?\d+(?:\.\d+)*(?:\s*,\s*[+-]?\d*\.?\d+(?:\.\d+)*){9,}\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*[+-]?\\d*\\.?\\d+(?:\\.\\d+)*(?:\\s*,\\s*[+-]?\\d*\\.?\\d+(?:\\.\\d+)*){9,}\\s*$', 'gm')
const str = `2,2.5,.5, .678 ,39,1.4.4.8,2.4,2.5,2.6,2.7
1,2,3,4,5,6,7, 8 , 9,0
.1,.2,.3.33.33,.4.5.4,8,9,8,7,.0,0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}