package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[{2}[^[\]]+\]{2}`)
var str = `some text [[someword]] some [[some other word]]other text `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}