re = /\[{2}[^[\]]+\]{2}/m
str = 'some text [[someword]] some [[some other word]]other text '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end