#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Port-channel(?<Port_id>.*)"
Local $sString = "type interface" & @CRLF & _
"Port-channel Port-channel1" & @CRLF & _
"Port-channel Port-channel261" & @CRLF & _
"Port-channel Port-channel100" & @CRLF & _
"Port-channel Port-channel99.202" & @CRLF & _
"Port-channel Port-channel99.200" & @CRLF & _
"Port-channel Port-channel99.160" & @CRLF & _
"Port-channel Port-channel99.159" & @CRLF & _
"Port-channel Port-channel99.158" & @CRLF & _
"Port-channel Port-channel99.157"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")