$re = '/Port-channel(?<Port_id>.*)/m';
$str = 'type interface
Port-channel Port-channel1
Port-channel Port-channel261
Port-channel Port-channel100
Port-channel Port-channel99.202
Port-channel Port-channel99.200
Port-channel Port-channel99.160
Port-channel Port-channel99.159
Port-channel Port-channel99.158
Port-channel Port-channel99.157';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);