import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Port-channel(?<Port_id>.*)";
final String string = "type interface\n"
+ "Port-channel Port-channel1\n"
+ "Port-channel Port-channel261\n"
+ "Port-channel Port-channel100\n"
+ "Port-channel Port-channel99.202\n"
+ "Port-channel Port-channel99.200\n"
+ "Port-channel Port-channel99.160\n"
+ "Port-channel Port-channel99.159\n"
+ "Port-channel Port-channel99.158\n"
+ "Port-channel Port-channel99.157";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}