#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,3}(?:\.\d\d\d)*(?:,\d{1,2})?$"
Local $sString = "0,25" & @CRLF & _
"1,25" & @CRLF & _
"125,00" & @CRLF & _
"1.250,00" & @CRLF & _
"1.250.000,25" & @CRLF & _
"1.250.000.000,25" & @CRLF & _
"1.250.000.000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")