package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,3}(?:\.\d\d\d)*(?:,\d{1,2})?$`)
var str = `0,25
1,25
125,00
1.250,00
1.250.000,25
1.250.000.000,25
1.250.000.000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}