$re = '/^\d{1,3}(?:\.\d\d\d)*(?:,\d{1,2})?$/m';
$str = '0,25
1,25
125,00
1.250,00
1.250.000,25
1.250.000.000,25
1.250.000.000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);