const regex = /^([^\|\n]+?)\|(rr)\|(?:([^\n]*?)(?:\|(ahk|kts)\|)+([^\n]*?)$)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\|\\n]+?)\\|(rr)\\|(?:([^\\n]*?)(?:\\|(ahk|kts)\\|)+([^\\n]*?)$)*', 'gm')
const str = `Possibilities simple:
string line. type everything you like and try.
Possibilities with programming:
keyValue|rr|sendValue|ahk|codeValue
keyValue|rr||ahk|codeValue
keyValue|rr||ahk|codeValue
synonomValue|rr|
synonymValue|rr||ahk|q=keyValue
and there are some special commands not listed above
key:\$1 __ rr:\$2 __ send:\$3 __ lang:\$4 __ code:\$5
lang code be ahk,kts or empty if used this rules above
keyValue|r|string
or a combination of both:
keyValue|rr|string|ahk|cooding
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}