re = /^([^\|\n]+?)\|(rr)\|(?:([^\n]*?)(?:\|(ahk|kts)\|)+([^\n]*?)$)*/m
str = 'Possibilities simple:
string line. type everything you like and try.
Possibilities with programming:
keyValue|rr|sendValue|ahk|codeValue
keyValue|rr||ahk|codeValue
keyValue|rr||ahk|codeValue
synonomValue|rr|
synonymValue|rr||ahk|q=keyValue
and there are some special commands not listed above
key:$1 __ rr:$2 __ send:$3 __ lang:$4 __ code:$5
lang code be ahk,kts or empty if used this rules above
keyValue|r|string
or a combination of both:
keyValue|rr|string|ahk|cooding
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end