// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^\|\n]+?)\|(rr)\|(?:([^\n]*?)(?:\|(ahk|kts)\|)+([^\n]*?)$)*").unwrap();
let string = "Possibilities simple:
string line. type everything you like and try.
Possibilities with programming:
keyValue|rr|sendValue|ahk|codeValue
keyValue|rr||ahk|codeValue
keyValue|rr||ahk|codeValue
synonomValue|rr|
synonymValue|rr||ahk|q=keyValue
and there are some special commands not listed above
key:$1 __ rr:$2 __ send:$3 __ lang:$4 __ code:$5
lang code be ahk,kts or empty if used this rules above
keyValue|r|string
or a combination of both:
keyValue|rr|string|ahk|cooding
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}