#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/lh5\.googleusercontent\.com\/p\/(?<id>[^\=]+)"
Local $sString = " {" & @CRLF & _
" thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipNolq_OR7cT2d3ayKRLkl2mb9s-mv0mqAJPLHX1=w203-h270-k-no'" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipOFU4c4duAkT22OigHgGtIu7U3naFNw_uiBPeK2=w203-h270-k-no'" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipOuAg_x3ITU1I32KiWZGBzgwQAU4UXf4GB5Z9PS=w203-h270-k-no'" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipMtjVGORN2eq-6kIjCrkW3biGo3cMVazFNBfz2r=w203-h152-k-no'" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipNsjaDdvAQrRboCbdVmcRA83c6DUBZ4YZvTDa8d=w203-h270-k-no'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")