package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/lh5\.googleusercontent\.com\/p\/(?<id>[^\=]+)`)
var str = ` {
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipNolq_OR7cT2d3ayKRLkl2mb9s-mv0mqAJPLHX1=w203-h270-k-no'
},
{
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipOFU4c4duAkT22OigHgGtIu7U3naFNw_uiBPeK2=w203-h270-k-no'
},
{
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipOuAg_x3ITU1I32KiWZGBzgwQAU4UXf4GB5Z9PS=w203-h270-k-no'
},
{
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipMtjVGORN2eq-6kIjCrkW3biGo3cMVazFNBfz2r=w203-h152-k-no'
},
{
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipNsjaDdvAQrRboCbdVmcRA83c6DUBZ4YZvTDa8d=w203-h270-k-no'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}