const regex = /https:\/\/lh5\.googleusercontent\.com\/p\/(?<id>[^\=]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/lh5\\.googleusercontent\\.com\\\/p\\\/(?<id>[^\\=]+)', 'gm')
const str = ` {
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipNolq_OR7cT2d3ayKRLkl2mb9s-mv0mqAJPLHX1=w203-h270-k-no'
},
{
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipOFU4c4duAkT22OigHgGtIu7U3naFNw_uiBPeK2=w203-h270-k-no'
},
{
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipOuAg_x3ITU1I32KiWZGBzgwQAU4UXf4GB5Z9PS=w203-h270-k-no'
},
{
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipMtjVGORN2eq-6kIjCrkW3biGo3cMVazFNBfz2r=w203-h152-k-no'
},
{
thumbnail: 'https://lh5.googleusercontent.com/p/AF1QipNsjaDdvAQrRboCbdVmcRA83c6DUBZ4YZvTDa8d=w203-h270-k-no'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}