#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)UC[A-Z]+[0-9]+"
Local $sString = "UCF123" & @CRLF & _
"" & @CRLF & _
"UCP123" & @CRLF & _
"" & @CRLF & _
"UCT123" & @CRLF & _
"" & @CRLF & _
"UCFL123" & @CRLF & _
"" & @CRLF & _
"UCFC123" & @CRLF & _
"" & @CRLF & _
"UCFA123" & @CRLF & _
"" & @CRLF & _
"UCPA123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")