package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)UC[A-Z]+[0-9]+`)
var str = `UCF123
UCP123
UCT123
UCFL123
UCFC123
UCFA123
UCPA123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}