using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"UC[A-Z]+[0-9]+";
string input = @"UCF123
UCP123
UCT123
UCFL123
UCFC123
UCFA123
UCPA123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}