#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sim)(192.168.1.\d{1,3}).*?((\w{2}[:]){5}(\w{2}))"
Local $sString = "{" & @CRLF & _
" "34:d2:70:87:42:68;": [" & @CRLF & _
" "192.168.1.81"," & @CRLF & _
" "\"amazon-8dee0891a\";"" & @CRLF & _
" ]," & @CRLF & _
" "98:e0:d9:91:bc:71;": [" & @CRLF & _
" "192.168.1.32"," & @CRLF & _
" "\"Cathys-Air\";"" & @CRLF & _
" ]," & @CRLF & _
" "88:71:e5:b3:cb:4e;": [" & @CRLF & _
" "192.168.1.172"," & @CRLF & _
" "\"amazon-205f4e28e\";"" & @CRLF & _
" ]," & @CRLF & _
" "34:d2:70:7f:df:e7;": [" & @CRLF & _
" "192.168.1.76"," & @CRLF & _
" "\"amazon-8b38e6c4e\";"" & @CRLF & _
" ]," & @CRLF & _
" "88:71:e5:a2:ff:66;": [" & @CRLF & _
" "192.168.1.77"," & @CRLF & _
" "\"amazon-43faa4ef3\";"" & @CRLF & _
" ]," & @CRLF & _
" "b8:3e:59:f1:73:9f;": [" & @CRLF & _
" "192.168.1.190"," & @CRLF & _
" "\"Roku"" & @CRLF & _
" ]," & @CRLF & _
" "18:b4:30:14:bc:da;": [" & @CRLF & _
" "192.168.1.179"," & @CRLF & _
" "\"02AA01AC42140DKR\";"" & @CRLF & _
" ]," & @CRLF & _
" "ac:d1:b8:4d:a3:85;": [" & @CRLF & _
" "192.168.1.180"," & @CRLF & _
" "\"NPI4DA385\";"" & @CRLF & _
" ]," & @CRLF & _
" "14:91:82:c9:8b:61;": [" & @CRLF & _
" "192.168.1.174"," & @CRLF & _
" "\"wemo\";"" & @CRLF & _
" ]," & @CRLF & _
" "14:91:82:00:d5:35;": [" & @CRLF & _
" "192.168.1.184"," & @CRLF & _
" "\"wemo\";"" & @CRLF & _
" ]," & @CRLF & _
" "08:00:27:89:03:db;": ["
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")