# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(192.168.1.\d{1,3}).*?((\w{2}[:]){5}(\w{2}))"
test_str = ("{\n"
" \"34:d2:70:87:42:68;\": [\n"
" \"192.168.1.81\",\n"
" \"\\\"amazon-8dee0891a\\\";\"\n"
" ],\n"
" \"98:e0:d9:91:bc:71;\": [\n"
" \"192.168.1.32\",\n"
" \"\\\"Cathys-Air\\\";\"\n"
" ],\n"
" \"88:71:e5:b3:cb:4e;\": [\n"
" \"192.168.1.172\",\n"
" \"\\\"amazon-205f4e28e\\\";\"\n"
" ],\n"
" \"34:d2:70:7f:df:e7;\": [\n"
" \"192.168.1.76\",\n"
" \"\\\"amazon-8b38e6c4e\\\";\"\n"
" ],\n"
" \"88:71:e5:a2:ff:66;\": [\n"
" \"192.168.1.77\",\n"
" \"\\\"amazon-43faa4ef3\\\";\"\n"
" ],\n"
" \"b8:3e:59:f1:73:9f;\": [\n"
" \"192.168.1.190\",\n"
" \"\\\"Roku\"\n"
" ],\n"
" \"18:b4:30:14:bc:da;\": [\n"
" \"192.168.1.179\",\n"
" \"\\\"02AA01AC42140DKR\\\";\"\n"
" ],\n"
" \"ac:d1:b8:4d:a3:85;\": [\n"
" \"192.168.1.180\",\n"
" \"\\\"NPI4DA385\\\";\"\n"
" ],\n"
" \"14:91:82:c9:8b:61;\": [\n"
" \"192.168.1.174\",\n"
" \"\\\"wemo\\\";\"\n"
" ],\n"
" \"14:91:82:00:d5:35;\": [\n"
" \"192.168.1.184\",\n"
" \"\\\"wemo\\\";\"\n"
" ],\n"
" \"08:00:27:89:03:db;\": [")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.