const regex = /(?:https?:\/\/)?(?:www\.)?youtu(?:be)?\.(?:com|be)(?:\/watch\/?\?v=|\/embed\/|\/shorts\/|\/)(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:\\\/\\\/)?(?:www\\.)?youtu(?:be)?\\.(?:com|be)(?:\\\/watch\\\/?\\?v=|\\\/embed\\\/|\\\/shorts\\\/|\\\/)(\\w+)', 'g')
const str = `https://www.youtube.com/watch?v=aQt9BumzZ7M
https://youtu.be/eGJWz3E5HrU
https://www.youtube.com/embed/eGJWz3E5HrU`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}