import re
regex = re.compile(r"(?:https?:\/\/)?(?:www\.)?youtu(?:be)?\.(?:com|be)(?:\/watch\/?\?v=|\/embed\/|\/shorts\/|\/)(\w+)")
test_str = ("https://www.youtube.com/watch?v=aQt9BumzZ7M\n"
"https://youtu.be/eGJWz3E5HrU\n"
"https://www.youtube.com/embed/eGJWz3E5HrU")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")