re = /(?:https?:\/\/)?(?:www\.)?youtu(?:be)?\.(?:com|be)(?:\/watch\/?\?v=|\/embed\/|\/shorts\/|\/)(\w+)/
str = 'https://www.youtube.com/watch?v=aQt9BumzZ7M
https://youtu.be/eGJWz3E5HrU
https://www.youtube.com/embed/eGJWz3E5HrU'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end