$re = '/\d\.\d+\s+ZQ\s+(\S+(?:\s\S+)*)/m';
$str = 'DE1ALAT0002 32.4756 -86.4393 106.1 ZQ DISNAY LAND 2.0 GCP 23456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);