re = /\d\.\d+\s+ZQ\s+(\S+(?:\s\S+)*)/m
str = 'DE1ALAT0002 32.4756 -86.4393 106.1 ZQ DISNAY LAND 2.0 GCP 23456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end