#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\]\s([A-Za-z\s\-]*)(?:\s\-)?\s\d"
Local $sString = "[Coalgirls] Mawaru Penguindrum 11 (1280x720_Blu-ray_FLAC)" & @CRLF & _
"" & @CRLF & _
"[FFF] Saenai Heroine no Sodatekata - 04 [BD][720p-AAC][28020890]" & @CRLF & _
"" & @CRLF & _
"[HorribleSubs] OverLord - 01 [720p]" & @CRLF & _
"" & @CRLF & _
"[HorribleSubs] The World God Only Knows - 11 [720p]" & @CRLF & _
"" & @CRLF & _
"[Doki] Zero no Tsukaima - F - 05 (1280x720 Hi10P BD FLAC) [6EE7D53B]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")