use strict;
my $str = '[Coalgirls] Mawaru Penguindrum 11 (1280x720_Blu-ray_FLAC)
[FFF] Saenai Heroine no Sodatekata - 04 [BD][720p-AAC][28020890]
[HorribleSubs] OverLord - 01 [720p]
[HorribleSubs] The World God Only Knows - 11 [720p]
[Doki] Zero no Tsukaima - F - 05 (1280x720 Hi10P BD FLAC) [6EE7D53B]';
my $regex = qr/\]\s([A-Za-z\s\-]*)(?:\s\-)?\s\d/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}