package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\]\s([A-Za-z\s\-]*)(?:\s\-)?\s\d`)
var str = `[Coalgirls] Mawaru Penguindrum 11 (1280x720_Blu-ray_FLAC)
[FFF] Saenai Heroine no Sodatekata - 04 [BD][720p-AAC][28020890]
[HorribleSubs] OverLord - 01 [720p]
[HorribleSubs] The World God Only Knows - 11 [720p]
[Doki] Zero no Tsukaima - F - 05 (1280x720 Hi10P BD FLAC) [6EE7D53B]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}